Задать вопрос
31 июля, 03:26

Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей выясните являються эти поля одного цвета

+5
Ответы (1)
  1. 31 июля, 05:14
    0
    1.

    var k, l, m, n: integer;

    begin

    readln (k, l, m, n) ;

    if (k+l+m+n mod 2 = 0) then

    writeln ('поля одного цвета')

    else

    writeln ('поля разных цветов')

    end.

    2.

    uses crt; {В зависимости от компилятора эта строчка может оказаться лишней}

    var question, answer: integer;

    begin

    randomize () ;

    question : = random (100) ;

    writeln (question) ;

    readln (answer) ;

    if (question+answer=100) then

    writeln ('Not bad')

    else

    writeln ('Oops. Right answer is ', 100-question)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей выясните ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. Напишите программу, которая по введенным координатам двух полей (k, l) и (m, n) определяет, являются ли эти поля полями одного цвета.
Ответы (1)
Делфи. Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8: первое число - номер вертикали (при счете слева направо), второе - номер горизонтали (при счете снизу-вверх).
Ответы (1)
Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки) Одного ли цвета эти клетки на шахматной доске? Вывести в выходной файл сообщение YES, если они одного цвета, и NO иначе
Ответы (2)
Поле шахматной доски определяется парой целых чисел - но - мером строки (от 1 до 8) и номером столбца (от 1 до 8). Пусть заданы два поля: (k, l) и (m, n).
Ответы (1)
Как решить задачу - Даны координаты двух полей шахматной доски. Координаты клетки - это два числа от 1 до 8: номер столбца и номер строки. Одного ли цвета эти клетки на шахматной доске? Надо сделать в Паскале
Ответы (1)