Задать вопрос
2 апреля, 22:53

2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление площади треугольника.

Введите (через пробел) длины двух сторон (см) треугольника

= 25 17

Введите величину угла между сторонами треугольника

= 30

Площадь треугольника: 106.25 кв. см.

+5
Ответы (1)
  1. 3 апреля, 00:12
    0
    Var

    a, b, alpha, s:real;

    begin

    writeln ('Вычисление площади треугольника') ;

    writeln ('Введите (через пробел) длины двух сторон (см) треугольника') ;

    readln (a, b) ;

    writeln ('Введите величину угла (градус) между сторонами треугольника') ;

    readln (alpha) ;

    alpha:=DegToRad (alpha) ;

    writeln ('Площадь треугольника: ',0.5*a*b*sin (alpha),' кв. см.')

    end.

    Тестовое решение:

    Вычисление площади треугольника

    Введите (через пробел) длины двух сторон (см) треугольника

    25 17

    Введите величину угла (градус) между сторонами треугольника

    30

    Площадь треугольника: 106.25 кв. см.

    Вычисление площади треугольника

    Введите (через пробел) длины двух сторон (см) треугольника

    11 16.3

    Введите величину угла (градус) между сторонами треугольника

    39

    Площадь треугольника: 56.4185730576179 кв. см.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. Ниже ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Turbo Pascal Написать программу вычисления объема цилиндра. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление объема цилиндра.
Ответы (1)
Написать программу вычисления расстояния между населенными пунктами, изображенными на карте. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Ответы (1)
Написать программу вычисления стоимости некоторого количества (по весу) яблок. Нижепредставлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки.
Ответы (1)
Написать программу вычисления стоимости некоторого количества (по весу) яблок. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки.
Ответы (1)
Составьте блок-схему и прогроамму на языке PascalABC для вычисления площади прямоугольника. Рекомендуемый вид экрана во время работы приведён ниже (данные, введённые пользователем выделены полужирным шрифтом).
Ответы (1)