Задать вопрос
3 февраля, 09:16

Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.

+1
Ответы (1)
  1. 3 февраля, 11:13
    0
    Var p, k, i:integer; f:boolean;

    begin

    f:=false;

    p:=32;

    while not f do

    begin

    p:=p+1;

    k:=2;

    for i:=2 to p div 2 do

    if p mod i = 0 then k:=k+1;

    f:=k=32;

    end;

    writeln (p) ;

    end.

    Результат:

    840
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы