Задать вопрос
3 августа, 23:16

Написать программу на алгоритмическом языке Паскаль. Вывести наименование и стоимость продукта, которого на складе меньше всего.

+1
Ответы (1)
  1. 3 августа, 23:52
    0
    Const

    nm = 50; { предельное число товаров }

    var

    mn: array[1 ... nm] of string;

    mk, ms: array[1 ... nm] of real;

    i, k, n: integer;

    min: real;

    begin

    Write ('Введите число продуктов на складе (не более ', nm, ') : ') ;

    Readln (n) ;

    min : = 1e10;

    for i : = 1 to n do

    begin

    Write ('Наименование продукта ', i, ': ') ; Readln (mn[i]) ;

    Write ('Количество и стоимость: ') ; Readln (mk[i], ms[i]) ;

    if min > mk[i] then begin min : = mk[i]; k : = i end

    end;

    Writeln ('На складе меньше всего продукта ', mn[k], ': ', mk[k],

    ' кг. стоимостью ', ms[k], ' руб. за 1 кг.')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на алгоритмическом языке Паскаль. Вывести наименование и стоимость продукта, которого на складе меньше всего. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы