Задать вопрос
28 марта, 18:26

Дано n последовательных натуральных чисел начиная с 1. Написать программу, вычисляющую их среднее арифметическое

+1
Ответы (1)
  1. 28 марта, 19:40
    0
    Import java. util. Scanner;

    import java. io.*;

    public class Sred {

    public static void main (String[] args) {

    Scanner in = new Scanner (System. in) ;

    int n;

    System. out. print ("n=") ;

    n = in. nextInt () ;

    int[] a = new int[n];

    int sum = 0;

    for (int i = 0; i < n; i++) {

    a[i] = in. nextInt () ;

    sum + = a[i];

    }

    float sred = (float) sum / n;

    System. out. printf ("Среднее арифметическое: %.1f / n", sred) ;

    }

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано n последовательных натуральных чисел начиная с 1. Написать программу, вычисляющую их среднее арифметическое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы