Задать вопрос
1 декабря, 17:21

Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет.

+3
Ответы (1)
  1. 1 декабря, 18:02
    0
    Program gt;

    var s, q, n:integer;

    begin

    s:=0;

    while n>0 do

    begin

    q:=n mod 10;

    n:=n div 10;

    s:=s+q;

    end;

    writeln (s) ;

    if (n mod 2=0) then writeln ('четное') else writeln ('не четное') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы