Задать вопрос
8 апреля, 10:47

Вычислить сумму ряда до n количества значений S=1 + 1/2+1/4+1 / (8) ...

напишите программу в паскале

+2
Ответы (1)
  1. 8 апреля, 11:58
    0
    Не очень корректная постановка задачи, но понять можно.

    var n, i:integer; s, a:real;

    begin

    write ('n=') ; readln (n) ;

    s:=1; a:=1;

    for i:=2 to n do

    begin

    a:=a*2; s:=s+1/a;

    end;

    writeln ('s=', s:6:4) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вычислить сумму ряда до n количества значений S=1 + 1/2+1/4+1 / (8) ... напишите программу в паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы