Задать вопрос
22 декабря, 03:39

Написать программу на Паскале которая запрашивает трёхзначное число, затем с помощью функций Div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". Если да, то печатает "имеется" иначе "не имеется

+2
Ответы (1)
  1. 22 декабря, 07:11
    0
    Var N, k, y: integer;

    begin

    write ('Введите число: ') ;

    readln (N) ;

    k : = 0;

    repeat

    y : = N mod 10;

    if y = 5 then k : = k + 1;

    N : = N div 10;

    until N = 0;

    if k 0 then writeln ('Имеется')

    else writeln ('Не имеется')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Паскале которая запрашивает трёхзначное число, затем с помощью функций Div mod разделяет число на цифры и проверяет ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы