Задать вопрос
24 марта, 17:04

Составить программу, которая заполняет одномерный массив из 20 элементов случайными целыми числами от 1 до 99, а затем определяет, сколько в массиве имеется простых чисел (простым числом называется такое, которое делится только на единицу или само на себя). Процесс определения того, является ли число простым, оформить в виде отдельной процедуры.

+5
Ответы (1)
  1. 24 марта, 20:30
    0
    Procedure P (Const A:integer; Var p:integer) ;

    Var

    K:real;

    d:integer;

    Begin

    if A > 1 then

    if (A = 2) or (A = 3) then p:=p+1

    else

    if A mod 2 0 then

    Begin

    K:=Sqrt (A) ;

    d:=3;

    While (d
    d:=d+2;

    if A mod d 0 then

    Begin

    p:=p+1;

    Write (' (простое) ')

    End

    End;

    End;

    Const

    N = 20;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    Randomize;

    k:=0;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (99) + 1;

    Write (' ', A[i]) ;

    P (A[i], k) ;

    End;

    WriteLn;

    WriteLn ('Кол-во простых чисел в массиве: ', k) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая заполняет одномерный массив из 20 элементов случайными целыми числами от 1 до 99, а затем определяет, сколько ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы