Задать вопрос
9 апреля, 16:18

50+лучший

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел

(массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.

+1
Ответы (2)
  1. 9 апреля, 17:25
    0
    Var i: integer;

    a, s: real;

    begin

    s:=0;

    writeln ('числа:') ;

    for i:=1 to 10 do

    begin

    write (i,': ') ;

    readln (a) ;

    s:=s+a;

    end;

    writeln ('среднее арифметическое: ', s/10:6:2) ;

    end.
  2. 9 апреля, 19:50
    0
    Через while:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0; i:=0;

    while i < 10 do

    begin

    readln (x) ;

    s : = s + x;

    inc (i) ;

    end;

    sr : = s / i;

    writeln (sr) ;

    end.

    Через repeat:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0; i:=0;

    repeat

    readln (x) ;

    s : = s + x;

    inc (i) ;

    until i = 10;

    sr : = s / i;

    writeln (sr) ;

    end.

    Через For:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    readln (x) ;

    s : = s + x;

    end;

    sr : = s / i;

    writeln (sr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «50+лучший Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы