Задать вопрос
10 июля, 05:15

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата

+4
Ответы (1)
  1. 10 июля, 05:36
    0
    Var

    a, r, rvp, rop:real;

    begin

    Write ('Введите сторону квадрата и радиус окружности: ') ;

    Readln (a, r) ;

    rvp:=a/2; rop:=a*sqrt (2) / 2;

    if r
    else

    if r=rvp then Writeln ('Введен радиус вписанной окружности')

    else

    if r
    else

    if r=rop then Writeln ('Введен радиус описанной окружности')

    else Writeln ('Окружность расположена вне описанной')

    end.

    Тестовое решение:

    Введите сторону квадрата и радиус окружности: 8 5

    Окружность расположена между вписанной и описанной
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы