Задать вопрос
2 декабря, 05:49

Pascal Вывести для каждого заданного числа количество цифр.

Формат ввода:

Элементы последовательности (целые числа в диапазоне от - 30000 до 30000) заданы по одному на строке через пробел. Признак окончание последовательности - число 0 (в последовательность не входит).

Формат вывода:

Целое число.

Пример входных данных

1 - 23 - 31 486 0

Пример выходных данных

1223

+1
Ответы (1)
  1. 2 декабря, 06:12
    0
    Var

    i, n, k:longint;

    a:array [1 ... 30000] of longint;

    begin

    n:=0;

    for i:=1 to 30000 do

    begin

    read (a[i]) ;

    if a[i]0

    then n:=n+1

    else break;

    end;

    for i:=1 to n do

    begin

    k:=0;

    while a[i]0 do

    begin

    a[i]:=a[i] div 10;

    k:=k+1;

    end;

    writeln (k,' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal Вывести для каждого заданного числа количество цифр. Формат ввода: Элементы последовательности (целые числа в диапазоне от - 30000 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы