Задать вопрос
5 февраля, 08:41

Помогите написать программу на Pascal

Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N. По заданному N найти число X (значение N вводится с клавиатуры, 10<=N<=999, и при этом число десятков в N не равно нулю).

+1
Ответы (1)
  1. 5 февраля, 11:32
    0
    Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец.

    var

    N: integer;

    begin

    readln (N) ;

    write (10 * (N mod 100) + (N div 100))

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы