Задать вопрос
30 мая, 01:24

9. Написать программу вычисления функции у: у=sqrt (х+5). если x>0. у = sqrt (5+х), если x<=0 В случае отрицательного подкоренного выражения выводится надпись "Останов" и программа заканчивается.

+4
Ответы (1)
  1. 30 мая, 01:40
    0
    Программа вкратце.

    Если посещал уроки то сможешь ее написать чтоб работала.

    В условии задачи ошибка, наверное вместо - написал плюс.

    y = sqrt (х+5). если x>0.

    пусть здесь будет так: у = sqrt (5-х). если x<0

    Program radical;

    var x, y:integer;

    Begin

    readln (x) ;

    if ((x+5) > = 0) and ((5-х) >=0)) then begin

    { проверка чтобы не-было меньше нуля }

    if (x>0) then

    y = sqrt (x+5) ;

    else if (x<0) then

    y = sqrt (5-x) ;

    writeln ('результат=', y) ;

    end

    else

    writeln ("нельзя извлечь корень из отрицательного числа") ;

    readln () ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «9. Написать программу вычисления функции у: у=sqrt (х+5). если x>0. у = sqrt (5+х), если x ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы