Задать вопрос
17 июня, 01:28

Даны 3 числа, написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел

+1
Ответы (1)
  1. 17 июня, 04:39
    0
    Program p2;

    Var a, b, c:integer;

    kolichestvo:byte;

    summa:integer;

    Begin

    kolichestvo:=0;

    summa:=0;

    Readln (a) ;

    If a<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+a;

    Readln (b) ;

    If b<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+b;

    Readln (c) ;

    If c<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+c;

    Writeln ('Количество отрицательных = ', kolichestvo) ;

    Writeln ('Сумма положительных = ', summa) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны 3 числа, написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы