Задать вопрос
10 сентября, 21:09

требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры

+1
Ответы (1)
  1. 10 сентября, 21:56
    0
    Var a, b:integer; x:real;

    begin

    readln (a, b) ;

    x:=abs (b/a) ;

    writeln (x:0:2) ;

    end.

    АБС это модуль, но я могу и ошибаться, тогда

    var a, b:integer; x:real;

    begin

    readln (a, b) ;

    If a<0 then a:=a * (-1) ;

    If b<0 then b:=b * (-1) ;

    x:=abs (b/a) ;

    writeln (x:0:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)
Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)