Задать вопрос
12 июля, 00:23

Напишите программу в PaskalABC, которая в последовательности натуральных чисел определяет максимальное чётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число-максимальное чётное число.

Пример работы программы:

Входные данные: 3,10,99,42

Выходные данные: 42

+3
Ответы (1)
  1. 12 июля, 03:55
    0
    Var

    N, A, M:word;

    Begin

    Read (N) ;

    M:=0;

    For N:=1 to N do

    Begin

    Read (A) ;

    if (A>M) and (A mod 2 = 0) then M:=A;

    End;

    Write (M)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в PaskalABC, которая в последовательности натуральных чисел определяет максимальное чётное число. Программа получает на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы