Задать вопрос
3 мая, 23:15

Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1<=N<=200000000). Выходные данные: Вывести все простые делители натурального числа N в порядке их возрастания.

+1
Ответы (1)
  1. 4 мая, 01:15
    0
    Var i, k, n, m: integer;

    begin

    write ('N = ') ; readln (n) ;

    m:=round (sqrt (n)) ;

    i:=2; k:=1;

    repeat

    if (n mod i=0) then

    begin

    if ik then

    begin

    write (i,' ') ;

    k:=i;

    end;

    n:=n div i;

    m:=round (sqrt (n)) ;

    i:=1;

    end;

    i:=i+1;

    until i>m;

    if kn then writeln (n) ;

    end.

    N = 43021568

    2 163 1031

    N = 625

    5

    N = 189756328

    2 67 354023
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы