Задать вопрос
1 августа, 19:31

Числа Фибоначчи определяются следующими формулами: f0=f1=1;

fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать

+1
Ответы (1)
  1. 1 августа, 21:15
    0
    Program gt;

    var n, f1, f2, i, f:integer;

    begin

    readln (n) ;

    f1:=1; f2:=1;

    for i:=2 to n do

    begin

    f:=f1+f2;

    f1:=f2;

    f2:=f;

    end;

    writeln (f2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n= ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы