Задать вопрос
18 мая, 21:59

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине

+5
Ответы (1)
  1. 18 мая, 23:12
    0
    Var s:string; j, p:integer;

    begin readln (s) ; p:=0; for j:=1 to length (s) do if (s[j]='e') or (s[j]=o) then inc (p) ; writeln (p) ; readln end.

    var s:string; j, e, o:integer;

    begin

    readln (s) ; e:=0; o:=0;

    for j:=1 to length (s) do begin if s[j]='e' then inc (e) ; if s[j]=o then inc (o) ;

    if o > e then writeln ('o') ; if o < e writeln ('e') ; if o=e then writeln ('oe') ; readln

    end.

    Счет букв ведется для латинских строчных букв o и e.)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы