Задать вопрос
2 июля, 17:10

Нужно написать программу в Паскале

Дан механизм, состоящий из двух шестеренок. У одной шестеренки N зубцов, у другой K. Требуется найти какое минимальное число поворотов на один зубчик требуется сделать, чтобы шестеренки вернулись в исходное состояние.

+4
Ответы (1)
  1. 2 июля, 18:47
    0
    Program task;

    var i, n, k:longint;

    begin

    writeln ('n?') ;

    readln (n) ;

    writeln ('k?') ;

    readln (k) ;

    for i:=1 to n*k do begin

    if ((i mod n = 0) and (i mod k = 0)) then begin

    writeln (i) ;

    break;

    end;

    end;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу в Паскале Дан механизм, состоящий из двух шестеренок. У одной шестеренки N зубцов, у другой K. Требуется найти ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы