Задать вопрос
1 сентября, 13:43

Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов (десятков и единиц). Затем эти суммы выводятся на экран в порядке убывания (без пробелов). Напишите программу, которая моделирует работа автомата.

+1
Ответы (1)
  1. 1 сентября, 16:57
    0
    Program zadanie;

    Var a, b, s1, s2, n:integer;

    Begin

    Writeln ('Введите 3-х значное целое число') ;

    Readln (n) ;

    a:=n div 100;

    b: = (n div 10) mod 10;

    s1:=a+b;

    a: = (n mod 100) mod 10;

    s2:=a+b;

    Writeln (s1, s2) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы