Задать вопрос
10 января, 22:08

Написать программу в Паскале.

По заданному числу N определите знак числа.

Формат входных данных:

Во входном файле input. txt записано одно целое число N (-10000<=N<=10000)

Формат выходных данных:

если заданное число положительное, то в выходной файл output. txt выведите квадрат этого числа. Если заданное число отрицательное, то вывелите модуль этого числа. Если же заданное число - нуль, то и вывести надо нуль.

Примеры:

input. txt output. txt

5 25

-5 5

0 0

+1
Ответы (1)
  1. 11 января, 01:13
    0
    Это если алгоритм выполнить дословно:

    var

    f1, f2: Text;

    n: integer;

    begin

    Assign (f1, 'input. txt') ; Reset (f1) ;

    Assign (f2, 'output. txt') ; Rewrite (f2) ;

    Readln (f1, n) ;

    if n < 0 then Writeln (f2, abs (n))

    else

    if n = 0 then Writeln (f2, 0)

    else Writeln (f2, sqr (n)) ;

    Close (f1) ; Close (f2)

    end.

    А это, если учесть, что модуль нуля равен нулю:

    var

    f1, f2: Text;

    n: integer;

    begin

    Assign (f1, 'input. txt') ; Reset (f1) ;

    Assign (f2, 'output. txt') ; Rewrite (f2) ;

    Readln (f1, n) ;

    if n < = 0 then Writeln (f2, abs (n))

    else Writeln (f2, sqr (n)) ;

    Close (f1) ; Close (f2)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input. txt записано одно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы