Задать вопрос
14 января, 04:49

1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222)

2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)

Паскаль

+2
Ответы (1)
  1. 14 января, 05:28
    +1
    1)

    #include

    #include

    using namespace std;

    int main () {

    int a;

    cin >> a;

    int d = a%10;

    string s = "yes";

    while (abs (a) > 0) {

    if (a%10! = d) {

    s = "no";

    break;

    }

    a/=10;

    }

    cout << s << endl;

    }

    2)

    #include

    #include

    using namespace std;

    int main () {

    int a;

    cin >> a;

    int d = a%10;

    a/=10;

    string s = "no";

    while (abs (a) > 0) {

    if (a%10 = = d) {

    s = "yes";

    break;

    }

    d = a%10;

    a/=10;

    }

    cout << s << endl;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы