Задать вопрос
12 апреля, 12:26

написать программу с организацией ввода-вывода с помощью текстовых файлов.

В каждой задаче задается квадратная матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

+3
Ответы (1)
  1. 12 апреля, 15:12
    0
    var a:array[1 ... 10,1 ... 10]of integer;

    i, j, k, s:integer;

    begin

    for i:=1 to 10 do for j:=1 to 10 do a[i, j]:=random (9) + 1;

    for i:=1 to 10 do begin for j:=1 to 10 do write (a[i, j],' ') ; if j=10 then writeln; end;

    s:=1;

    for i:=2 to 10 do begin k:=a[i, 1];

    for j:=2 to 10 do begin

    if i mod 2 = 0 then if a[i, j]>k then k:=a[i, j];

    if (j=10) and (i mod 2=0) then s:=s*k;

    end;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы