Задать вопрос
21 июня, 17:22

Задача. Паскаль. Почему это решение не верно?

Студент Валера являет собой классический пример лентяя. На занятия он практически не ходит, и только в конце семестра появляется в университете и сдает "хвосты". Его заветная мечта: найти такой день, когда можно будет сдать сразу все долги. У него есть расписание работы преподавателей, из которого точно известно, с какого и по какой день месяца каждый преподаватель ежедневно будет доступен.

Помогите Валере написать программу, которая по расписанию будет определять, сможет ли Валера сдать все долги за один день или нет.

var

i, max, min, n:integer;

a, b:array[1 ... 100]of integer;

begin

read (n) ; max:=0; min:=32;

for i:=1 to n do

begin

read (a[i], b[i]) ;

if a[i]>max then max:=a[i];

if b[i] end;

if min>max then

writeln ('YES')

else writeln ('NO') ;

end.

+4
Ответы (1)
  1. 21 июня, 19:27
    0
    Var

    a, b:array[1 ... 100]of integer;

    i, max, min, n:integer;

    begin

    readln (n) ;

    max:=0; min:=32;

    for i:=1 to n do

    begin

    readln (a[i], b[i]) ;

    if a[i]>max then max:=a[i];

    if b[i]
    end;

    if min>=max then

    writeln ('YES')

    else writeln ('NO') ;

    end.

    Пример:

    3

    1 5

    3 10

    4 14

    YES
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача. Паскаль. Почему это решение не верно? Студент Валера являет собой классический пример лентяя. На занятия он практически не ходит, и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы