Задать вопрос
16 октября, 23:10

Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа.

Помогите написать программу в Паскале.

+2
Ответы (1)
  1. 17 октября, 02:55
    0
    Var

    n, i, p1, p2: integer;

    begin

    read (n) ;

    p2 : = n mod 10;

    while n > 0 do

    begin

    if (n div 10 < = 0) then p1 : = (n mod 10) ;

    n : = n div 10;

    end;

    write (p2 / p1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа. Помогите написать программу в Паскале. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы