Задать вопрос
23 апреля, 23:35

Найдите все простые числа на отрезке [a, b] их сумму и произведение

(составить программу в pascal)

+1
Ответы (1)
  1. 24 апреля, 00:47
    0
    Program n1;

    function isprost (x: integer) : boolean;

    var i: integer;

    begin

    if x<2 then isprost:=false else

    begin

    isprost:=true;

    for i : = 2 to round (sqrt (x)) do if x mod i = 0 then isprost:=false;

    end;

    end;

    var a, b, i, sum: integer;

    p: real;

    begin

    writeln ('введите границы отрезка [a; b] (предполагается, что числа натуральные) ') ;

    write ('a=') ;

    readln (a) ;

    write ('b=') ;

    readln (b) ;

    p:=1;

    sum:=0;

    if (a<=0) or (b<=0) then write ('ошибка, числа не натуральные')

    else begin

    writeln ('простые числа на отрезке [', a,'; ', b,']') ;

    for i:=a to b do if isprost (i) then

    begin

    p:=p*i;

    sum:=sum+i;

    write (i,' ') ;

    end;

    writeln;

    writeln ('их сумма: ', sum) ;

    writeln ('их произведение: ', p) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найдите все простые числа на отрезке [a, b] их сумму и произведение (составить программу в pascal) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы