Задать вопрос
10 августа, 03:16

Даны два целых числа от 1 до 1 000 000 000. Найти сумму этих чисел. Входные данные: два целых числа. Выходные данные: целое число. На Паскале

+1
Ответы (1)
  1. 10 августа, 06:05
    0
    Точная задача по Техническому Заданию:

    var x, y:integer;

    begin

    writeln ('введите два числа') ;

    readln (x) ;

    readln (y) ;

    if (x<1000000001) and (y0) and (y>0)

    then writeln ('сумма чисел = ', x+y)

    else writeln ('диапазон чисел неверный') ;

    end.

    Если вдруг вам поверит учитель, можете перевыполнить поставленную задачу:

    var x, y:integer;

    s:string;

    begin

    randomize;

    writeln ('взять ли числа случайными? Ответ да или нет') ;

    readln (s) ;

    if (s='да') or (s='Да') or (s='ДА') or (s='дА') then begin

    x:=random (1000000000) ;

    y:=random (1000000000) ;

    writeln ('сумма чисел = ', x+y) ;

    writeln ('произведение чисел = ', x*y) ;

    end

    else begin

    writeln ('введите два числа') ;

    readln (x) ;

    readln (y) ;

    writeln ('сумма чисел = ', x+y) ;

    writeln ('произведение чисел = ', x*y) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны два целых числа от 1 до 1 000 000 000. Найти сумму этих чисел. Входные данные: два целых числа. Выходные данные: целое число. На ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы