Задать вопрос
9 октября, 08:44

1. Что такое цикл?

2. Чем отличаются циклы с предусловием и постусловием?

3. Сколько раз выполнится цикл?

n:=0

while n<6 do

begin

s:=s+6;

n:=n+2;

end;

4. Какое число выведет на экран ПК после выполнения фрагмента программы?

For i:=1 to 5 do s:=20 - i;

write (s) ;

5. Найди и исправь ошибку.

n:=6;

repeat

s:=s+n;

until n>0

Средний уровень

6. Составь программу, вычисляющую сумму квадратов первых n натуральных чисел.

7. Ученик в первый день выучил 5 английских слов. В каждый следующий день он выучивал на 2 слова больше, чем в предыдущий. Составьте программу, вычисляющую сколько английских слов он выучит за n дней.

+2
Ответы (1)
  1. 9 октября, 12:00
    0
    Теории в интернете полно.

    3) 3 раза

    4) 5

    5) until n>6

    6) program zadanie;

    uses crt;

    Var

    n, k, i, S: integer;

    begin

    clrscr;

    writeln ('Введите n=') ;

    readln (n) ;

    for i:=1 to n do

    begin

    S:=S+i*i;

    end;

    writeln ('Сумма квадратов=', S) ;

    end.

    7) program zadanie2;

    uses crt;

    Var

    n: integer;

    begin

    clrscr;

    writeln ('Введите n=') ;

    readln (n) ;

    writeln ('Результат:', (5 + (n-1)) * n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Что такое цикл? 2. Чем отличаются циклы с предусловием и постусловием? 3. Сколько раз выполнится цикл? n:=0 while n0 Средний уровень 6. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы