Задать вопрос
9 ноября, 16:31

Дан двумерный массив целых чисел, i=10, j=15; заполняется случайными образом целыми числами от 0 до 100. Определите сколько раз в нём случается элемент со значением Х (Х-задаётся пользователем).

+5
Ответы (1)
  1. 9 ноября, 19:18
    0
    a:array[1 ... 10,1 ... 15] of integer;

    i, j, k, x:integer;

    begin

    read (x) ;

    k:=0;

    for j:=1 to 15 do

    for i:=1 to 10 do

    a[i, j]:=random (101) ;

    for j:=1 to 15 do

    for i:=1 to 10 do

    if a[i, j]=x then k:=k+1;

    write (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан двумерный массив целых чисел, i=10, j=15; заполняется случайными образом целыми числами от 0 до 100. Определите сколько раз в нём ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы