Задать вопрос
4 февраля, 05:20

1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А.

2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.

+2
Ответы (1)
  1. 4 февраля, 06:20
    0
    1) var ma:array[1 ... 3,1 ... 3] of integer;

    i, j, t:integer;

    begin;

    randomize;

    readln (t) ;

    writeln ('Matrix:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    ma[i, j]:=random (10) ;

    write (ma[i, j]:4) ;

    ma[i, j]:=ma[i, j]*t;

    end;

    end;

    writeln;

    writeln ('Final matrix:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    write (ma[i, j]:4) ;

    end;

    end.

    2) var ma:array of array of real;

    i, j, n, m, maxj, maxi:integer;

    max:real;

    begin;

    readln (n) ;

    readln (m) ;

    setlength (ma, n+1) ;

    for i:=1 to n do

    setlength (ma[i], m+1) ;

    max:=-2147483648;

    writeln ('Matrix:') ;

    for i:=1 to n do

    begin;

    writeln;

    for j:=1 to m do

    begin;

    ma[i, j]:=random (100) - 50;

    write (ma[i, j]:4) ;

    if (ma[i, j]max) then

    begin;

    max:=ma[i, j];

    maxi:=i;

    maxj:=j;

    end;

    end;

    end;

    writeln;

    writeln ('Max:', max) ;

    writeln ('Строка:', maxi) ;

    write ('Столбец:', maxj) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы