Задать вопрос
22 декабря, 00:47

Написать программу которая меняет 2 и 3 цифру в четырехзначном числе

+4
Ответы (1)
  1. 22 декабря, 03:42
    0
    Var a, a1, a2, a3, a4, b:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a1:=a div 1000;

    a2:=a div 100 mod 10;

    a3:=a mod 100 div 10;

    a4:=a mod 10;

    b:=a1*1000+a3*100+a2*10+a4;

    writeln ('b = ', b) ;

    end.

    Пример:

    a = 4682

    b = 4862
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая меняет 2 и 3 цифру в четырехзначном числе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы