Задать вопрос
16 марта, 00:54

Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ...

+1
Ответы (1)
  1. 16 марта, 01:54
    0
    program zadacha2;

    uses crt;

    var i, n, a:integer;

    b, y, c, l:real;

    begin

    clrscr;

    readln (n) ;

    a:=1;

    b:=2;

    c:=5;

    for i:=1 to n do

    begin

    if a mod 2 = 0 then

    l:=a+b/c

    else

    l:=a-b/c;

    a:=a+1;

    b:=b+2;

    c:=c+5;

    y:=y+l;

    end;

    writeln (y:2:2) ;

    readkey;

    end.

    Первую по подробней расспишите
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы