Задать вопрос
8 октября, 12:12

Составьте программу, которая позволяет заменить в строке слово мама на слово папа

+2
Ответы (1)
  1. 8 октября, 15:37
    0
    Var / / Объявляем переменные

    i:integer;

    s:string;

    begin / / Начало работы блока

    readln (s) ; / / В переменную S записываем введенную строку

    i : = Pos ('мама', s) ; / / В переменную i записываем количество символов до данного слова

    if i > 0 then / / Если количество символов больше нуля тогда

    begin

    Delete (s, i, 4) ; / / Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа

    Insert ('папа', s, i) ; / / Заменяем словом Папа

    end; / / Конец

    writeln (s) ; / / Выводим на экран полученный текст

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая позволяет заменить в строке слово мама на слово папа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы