Задать вопрос
21 декабря, 22:03

Составить программу формирования массива из 50 элементов, в которой используется признак Р, в зависимости от значения которого реализовывался бы один из способов задания массива: при Р = - 1 с помощью генератора случайных чисел, при Р=0 с помощью формулы А[i] = i + 101, при Р=1 с клавиатуры. Сделать вывод сформированного массива на экран.

+3
Ответы (1)
  1. 21 декабря, 23:20
    0
    Const n=50;

    var a: array[1 ... n] of integer;

    p, i: integer;

    begin

    write ('p (-1,0,1) = ') ;

    readln (p) ;

    case p of

    1: for i:=1 to n do a[i]:=random (100) ;

    0: for i:=1 to n do a[i]:=i+101;

    -1: begin for i:=1 to n do read (a[i]) ; readln; end;

    end;

    writeln;

    writeln ('Исходный массив:') ;

    for i:=1 to n do write (a[i],' ') ;

    writeln;

    end.

    Пример (для n=5) :

    p (-1,0,1) = 0

    Исходный массив:

    102 103 104 105 106
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу формирования массива из 50 элементов, в которой используется признак Р, в зависимости от значения которого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы