Задать вопрос
12 октября, 14:19

Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько потребуется плиток для укладки пола размером MxN, если резать плитку на части Чиполлино не умеет.

Входные данные: MxN - целые числа, размер пола.

Выходные данные: Целое число - кол-во плиток.

+2
Ответы (2)
  1. 12 октября, 16:11
    0
    Program gt1;

    label 3,9;

    var m, n, q, r, w, z, t:longint;

    begin

    read (m, n) ;

    w:=m;

    t:=n;

    3:

    q:=m div n;

    r:=m mod n;

    if (r=0) then goto 9;

    m:=n;

    n:=r;

    goto 3;

    9:

    z: = (w div n) * (t div n) ;

    write (z) ;

    end.
  2. 12 октября, 17:33
    0
    VB.

    Dim m, n as integer

    m=InputBox ("Введите m")

    n=InputBox ("Введите n")

    MsgBox ("Количество необходимых плиток - " & m*n)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы