Задать вопрос
23 февраля, 01:30

Составьте программу, которая позволяет удалить символы t из строки s. Строка s и символ t, который надо удалить, вводятся с клавиатуры

+4
Ответы (1)
  1. 23 февраля, 02:39
    0
    Тогда вот, все по букве задания

    var

    s : string;

    t : char;

    i : integer;

    begin

    readln (s) ;

    read (t) ;

    i : = 1;

    while (i < = length (s)) do

    begin

    if s[i] = t then delete (s, i, 1)

    else i : = i + 1;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая позволяет удалить символы t из строки s. Строка s и символ t, который надо удалить, вводятся с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы