Задать вопрос
26 ноября, 08:03

Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с объяснениями)

Написать модуль, содержащий процедуру нахождения минимальной цифры натурального числа. Привести пример использования данного модуля. (в Паскале)

+5
Ответы (1)
  1. 26 ноября, 09:23
    0
    Текст модуля (Free Pascal) :

    unit MyLib;

    interface

    procedure MinDigit (n:longint; var md:byte) ;

    implementation

    procedure MinDigit (n:longint; var md:byte) ;

    var

    d:byte;

    begin

    md:=10;

    while n>0 do begin

    d:=n mod 10;

    if d
    n:=n div 10

    end

    end;

    begin

    end.

    Тестовая программа:

    uses

    Crt, MyLib;

    var

    p:byte;

    begin

    ClrScr;

    MinDigit (45134, p) ;

    Writeln ('p=', p) ;

    ReadKey

    end.

    Тестовое решение:

    p=1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы