Задать вопрос
9 января, 15:08

1. Написать программу, которая вычисляет произведение цифр к-значного числа.

2. пусть элементами равносторон. треугольника являются: сторона a, высота h, площадь S, вписанная окружность r, описанная окружность R. составить программу, которая по заданному номеру и значению элемента, вычисляла бы значения всех остальных элементов

+2
Ответы (1)
  1. 9 января, 18:12
    0
    Решу только первую задачу.

    const k=?; {Вместо "?" подставить любое значение k}

    Var x, i, s:integer;

    Begin

    write ('x=') ;

    readln (x) ;

    s:=1;

    for i:=1 to k do

    begin

    s:=s * (x mod 10) ;

    x:=x div 10;

    end;

    writeln ('s=', s) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Написать программу, которая вычисляет произведение цифр к-значного числа. 2. пусть элементами равносторон. треугольника являются: ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы