Задать вопрос
26 апреля, 17:29

Дано 4579 число. Получить числа, образованные при перестановкой цифр заданного числа. (написать программу на паскале)

+5
Ответы (1)
  1. 26 апреля, 19:55
    0
    Var abcd, a, b, c, d:integer;

    begin

    abcd:=4579;

    a:=abcd div 1000;

    b:=abcd div 100 mod 10;

    c:=abcd div 10 mod 10;

    d:=abcd mod 10;

    Writeln (a, b, c, d) ;

    Writeln (a, c, b, d) ;

    Writeln (b, a, c, d) ;

    Writeln (b, c, a, d) ;

    Writeln (c, a, b, d) ;

    Writeln (c, b, a, d) ;

    Writeln (a, d, b, c) ;

    Writeln (a, d, c, b) ;

    Writeln (b, d, a, c) ;

    Writeln (b, d, c, a) ;

    Writeln (c, a, d, b) ;

    Writeln (c, b, d, a) ;

    Writeln (a, b, d, c) ;

    Writeln (a, c, d, b) ;

    Writeln (d, b, a, c) ;

    Writeln (d, b, c, a) ;

    Writeln (d, c, a, b) ;

    Writeln (d, c, b, a) ;

    end.

    Громозко, да? Я не помню, как делать это через функцию. Думаю, и так сойдет.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано 4579 число. Получить числа, образованные при перестановкой цифр заданного числа. (написать программу на паскале) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы