Задать вопрос
14 октября, 08:59

Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.

+1
Ответы (2)
  1. 14 октября, 10:26
    0
    program z1;

    uses crt;

    var x, y:integer;

    begin

    clrscr;

    writeln ('введи число') ;

    readln (x) ;

    if x>=0 then x:=x*2

    else

    if x<0 then sqr (x) ;

    writeln (x) ;

    readln;

    end.
  2. 14 октября, 12:38
    0
    Pascal ABC

    var a : integer;

    begin

    readln (a) ;

    If a > = 0 then a : = 2*a;

    If a < 0 then a : = a*a;

    writeln (a)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы