Задать вопрос
25 августа, 20:16

Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел и вычисляет их сумму.

+5
Ответы (1)
  1. 25 августа, 20:33
    0
    Ну так как знаю язык программы Dev-C++, напишу ... и если я не ошибаюсь это массив : -)

    #include

    main ()

    {

    int i, n;

    float s;

    printf ("n=") ;

    scanf ("%d", &n) ;

    int a[n];

    for (i=0; i {

    printf ("/n a[%d]=", i) ;

    scanf ("%d", &a[i]) ;

    }

    s=0;

    for (i=0; i s=s+a[i];

    printf ("s=%f", s) ;

    puts ("Massiv:") ;

    for (i=0; i printf ("/n a[%d]=%d", i, a[i]) ;

    getchar () ;

    return (0) ;

    }

    напишу краткое объяснение, 1 - пишем н, произвольное, это количемтво этих исел будет,

    2 - создаем массив с и (параметр массива) меньшим н ... там мы пишем эти числа, сумму которых нужно всчитать

    3 - находим сумму

    4 - пишем чемк она равна

    5 - выводим массив

    и все

    если программа не бкдет идти напиши вконце место return (0) ; = > getchar () ;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на любом известном вам алгоритмическом языке. На вход программе подается число N. Программа формирует N случайных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы