Задать вопрос
16 сентября, 03:16

Помогите составить программу, которая по сумме цифр определит делится ли число на 3 ...

+3
Ответы (1)
  1. 16 сентября, 03:27
    0
    Function Div3 (n:longint) : boolean;

    var s:byte;

    begin

    s:=0;

    while n>0 do

    begin

    s:=s+n mod 10;

    n:=n div 10;

    end;

    if s mod 3=0 then Div3:=true

    else Div3:=false;

    end;

    var a:longint;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    if Div3 (a) then write ('Число делится на 3')

    else write ('Число не делится на 3') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу, которая по сумме цифр определит делится ли число на 3 ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы