Задать вопрос
10 февраля, 19:45

Помогите написать программу (Pascal ABC)

Программирование циклических алгоритмов.

Дано натуральное число N. Вычислить

S=1+1/3+1/5+1/7 + ... + 1/2N+1

+5
Ответы (1)
  1. 10 февраля, 21:10
    0
    Var n, i:integer; s:real;

    begin

    readln (n) ;

    s:=0;

    for i:=0 to n do s:=s+1 / (2*i+1) ;

    writeln ('s = ', s) ;

    end.

    Пример:

    5

    s = 1.878210678210678e+00
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу (Pascal ABC) Программирование циклических алгоритмов. Дано натуральное число N. Вычислить S=1+1/3+1/5+1/7 + ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы