Задать вопрос
1 сентября, 14:18

Дана последовательность из N вещественных чисел. Переменной t присвоить значение true, если в последовательности нет нулевых элементов. Написать программу для Pascal ABC и блок-схему. Студенческий уровень.

+2
Ответы (1)
  1. 1 сентября, 17:20
    0
    Var

    N, i: integer;

    x: real;

    t: boolean;

    begin

    readln (N) ;

    i : = 0;

    repeat

    i : = i + 1;

    Readln (x) ;

    until (x < 0.001) or (i = N) ;

    t : = x > 0.001;

    writeln (t)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность из N вещественных чисел. Переменной t присвоить значение true, если в последовательности нет нулевых элементов. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы