Задать вопрос
20 февраля, 10:41

Нужно написать программу на паскале обязательно используя цикл For.

Программа вычисляет среднее арифметическое положительных элементов ряда чисел. Каждый элемент ряда вычисляется по формуле: (12*K-21) / 3, где K--номер элемента в ряду. Всего элементов--необходимо спросить.

+1
Ответы (1)
  1. 20 февраля, 11:49
    0
    Var K, n:integer;

    S:real;

    Begin

    n:=0;

    Write ('K = ') ; ReadLn (K) ;

    For K: = 1 to K do

    Begin

    Write ((12*K-21) / 3,' ') ;

    if (12*K-21) / 3 > 0 then

    Begin

    S:=S + (12*K-21) / 3;

    n:=n+1

    End;

    End;

    WriteLn;

    Write ('Sr = ', S/n)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу на паскале обязательно используя цикл For. Программа вычисляет среднее арифметическое положительных элементов ряда ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы