Задать вопрос
7 февраля, 22:33

В управляющий совет школы входят родители, учителя и учащиеся школы, причём родителей должно быть не менее одной трети от общего числа членов совета. В настоящий момент в совет входит N человек, из них K родителей. Определите, сколько родителей нужно дополнительно ввести в совет, чтобы их число стало составлять не менее трети от числа членов совета.

Программа получает на вход два целых числа N и K (N > 0, 0 ≤ K ≤ N ≤ 2⋅109), записанные в отдельных строках, - текущее число членов совета и число родителей в совете.

Программа должна вывести единственное число - минимальное число родителей, которое необходимо ввести в совет.

Ввод Вывод

27

7 3

Пример 2

Ввод Вывод

1

0 1

Пример 3

Ввод Вывод

7

1 2

+1
Ответы (1)
  1. 7 февраля, 23:36
    -1
    Если "родителей должно быть не менее одной трети" (т. е. больше или равно), то в первом примере (где n=27, k=7) ответ должен быть 2, а не 3. 7+2=9 - это как раз 1/3 от 27.

    var n, k, m:integer;

    begin

    writeln;

    readln (n) ;

    readln (k) ;

    m: = (n-1) div 3+1;

    if m-k>0 then writeln (m-k) else writeln (0) ;

    end.

    Пример:

    27

    7

    2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В управляющий совет школы входят родители, учителя и учащиеся школы, причём родителей должно быть не менее одной трети от общего числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы