Задать вопрос
18 августа, 21:32

Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)

+3
Ответы (1)
  1. 19 августа, 00:05
    0
    Var

    i, n, p:longint;

    begin

    Write ('Введите целое число n - > ') ; Readln (n) ;

    p:=1;

    for i:=2 to n do p:=p*i;

    Writeln ('n!=', p)

    end.

    Тестовое решение:

    Введите целое число n - > 5

    n!=120
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы