Задать вопрос
9 августа, 12:47

Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить,

сколько он будет стоить через N лет. (Pascal)

Пример:

Введите стоимость стола: 35000

Введите кол-во лет: 5

Стоимость стола на конец 1 года: 30800.000 рублей

Стоимость стола на конец 2 года: 27104.000 рублей

Стоимость стола на конец 3 года: 23851.520 рублей

Стоимость стола на конец 4 года: 20989.338 рублей

Стоимость стола на конец 5 года: 18470.617 рублей

+1
Ответы (1)
  1. 9 августа, 13:05
    0
    Program Schet;

    var

    i:integer;

    stoimost:real;

    godi:integer;

    Begin

    Write ('Введите стоимость стола: ') ;

    Readln (stoimost) ;

    Write ('Введите количество лет: ') ;

    Readln (godi) ;

    for i:=1 to godi do

    Begin

    stoimost-=stoimost*0.12;

    Writeln ('Стоимость стола на конец ' + i + ' года: '+stoimost) ;

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы